DOCUMENT NINJA – QUICK GUIDE

Introduction ........................................................................................................................................ 2
Word Template overview .................................................................................................................. 3
  Editing the title text ......................................................................................................................... 4
  Editing page contents ...................................................................................................................... 4
  Adding new pages ........................................................................................................................... 4
Powerpoint Template overview .......................................................................................................... 6
  Editing the title text ......................................................................................................................... 7
  Editing page contents ...................................................................................................................... 7
  Adding new pages ........................................................................................................................... 8
Adding your template doc to the Document Ninja ............................................................................ 9
Adding a Quiz ..................................................................................................................................... 13
  Quiz Settings ................................................................................................................................... 14
  Quiz Questions ............................................................................................................................... 18
Choosing the design of your course .................................................................................................... 23
  Carousel .......................................................................................................................................... 24
  Drop Down ....................................................................................................................................... 25
  Drop Up ........................................................................................................................................... 26
  Nano ............................................................................................................................................... 27
  Side Bar .......................................................................................................................................... 28
  No Design ........................................................................................................................................ 29
Downloading your course package ...................................................................................................... 30
Additional notes ............................................................................................................................... 32
Introduction

This documentation is provided to guide you through the process of using our templates to create courses easily and quickly using the Document Ninja.

There are two different template types available – Microsoft Word documents and Microsoft Powerpoint documents. Each type includes several variants, each of which have been adjusted to fit neatly into particular theme designs. The file names indicate what designs they should be used with:

- The templates marked carousel are to be used with the Carousel design.
- The templates marked dropup_dropdown are to be used with either the Drop Up or Drop Down designs.
- The templates marked nano_none are to be used with either the Nano or No Design designs.
- The templates marked sidebar are to be used with the Side Bar design.
Word Template overview

The Word documents have a basic structure, with each page being split into two sections – a text box, which contains the title text; and the content area, where all other text and features are placed.

Two pages are included by default – an initial page with sample text and instructions, and a second page with only sample text.
Editing the title text

To edit the page titles, click on the heading text to select it, then when the typing cursor appears, delete the default ‘page title’ text and type in your own content to replace it. There is room for two lines of text at the default font size (24px).

(Selecting the text inside a text box – note the dotted or ‘broken’ border lines)

Editing page contents

To edit the page contents, simply delete the ‘page content goes here’ text and type in your own content to replace it. You can also place images in this area by going to Insert > Picture (and adjusting its Wrap settings if need be).

This is my title!

This course contains some dummy text to demonstrate how you can type content into this template. We’re doing our best to ensure that these templates are quick and easy to use for your convenience.

Adding new pages

To create a new page, place the cursor at the end of the text on your current page, then go to Insert > Page Break.
If in older versions of Word, this may be under Page Layout > Breaks > Page Breaks (Page) instead.

To add a title to a new page, click once on the title text on your current page to select it, then either right click on the text box border and select Copy, or left click on the text border and hit Ctrl+C on your keyboard.

Then create your new page using a page break. Before you type anything on the new page, right click on the cursor and select Paste (Keep Source Formatting), or hit Ctrl+V on your keyboard. The text box will be pasted onto your new page.

**NOTE:** For content height consistency, we recommend that each page contains a title text box.

If you want to start editing text on the new page, click to the right of the text box and just start typing. It should look similar to the image below, with no text box outline or highlight visible. Don’t worry about the position of the cursor – text will automatically move to the next line when you type something.

Alternatively, you can type in some content first, then place the cursor at the beginning of your text and paste the heading text box there for the same result.
The Powerpoint documents have a similar structure to the Word template, with each page again being split into two sections – a text box, which contains the title text; and a content box below it for all other text and features.

Three pages are included by default – an initial page with sample text and instructions, a blank page with the same structure as the first, and another blank page with the content box split into two columns if you prefer.
Editing the title text

To edit the page titles, click on the heading text to select it, then when the typing cursor appears, delete the default ‘page title’ text and type in your own content to replace it. There is room for two lines of text at the default size (24px).

Editing page contents

To edit the page contents, simply click anywhere in the text box area and begin typing to enter your content.

You can also place an image into these areas by either going to Insert > Picture or clicking on the Picture button in the center of the provided content area. In older versions of Powerpoint, this may be labelled as Insert Picture from File instead.

NOTE: If you use the latter method to import an image, it will use up the content area, leaving it unusable for text or other images. If you need to add another text box, copy a content area from a blank template slide or go to Insert > Text Box to create a new one from scratch.
Adding new pages

To create a new page (and retain formatting settings), right click on one of the thumbnails for the blank template slides in the left hand list, the select *Duplicate Slide* from the menu that appears.

**NOTE:** To avoid any complications with formatting, it is highly recommended that you avoid deleting the two default slides until everything else in the document has been completed – this way, you always have them around to duplicate and/or copy and paste from if anything goes wrong in other slides.

You can also reorder slides by clicking and holding a slide thumbnail, then dragging it up or down the list to its new position.
Adding your template doc to the Document Ninja

When you are done editing your template document, launch the Document Ninja and open the **Add Documents** section. Drag and drop the file onto the ninja, or click the *UPLOAD from your computer* button and select your file. Either way, the document will then be uploaded, converted and its pages placed into the file list.

![Document Ninja interface](image)

**NOTE:** Before uploading your document, click the small gear icon in the top right corner of the **Document Ninja** window and check that ‘Auto-split documents’ is enabled.

![Auto-split documents](image)

If this is on, the document should automatically split into separate pages when uploaded to the **Ninja**. If this does not happen for any reason, click on the document in the file list to open it, then click the ‘Split’ button over on the right to do this manually.

![Split button](image)

Click on any page in the file list to open it. You then have several options available:
To rename a page, click on the title text field above the page content and type in the new name, then hit Enter/Return to save it.

To delete a page, click on the Delete Page button to the right of the title text field. You’ll be given a choice to confirm whether you want to do this – click Yes to delete the page or click No to keep it.

To reorder pages, go to the file list, click and hold the mouse on the wavy icon to the left of the page name, then drag up or down the list to move the page to its new position.

Pages can also be set to be either Parent or Child pages depending on whether they are indented or not in the file list. To change this setting, click on the switch icon to the left of the page name.

If a page is indented, it will be hidden in the table of contents when the course is played, until its parent page is selected.
NOTE: When a document is split, all pages (except for the first) will be child pages by default, so don’t forget to adjust them accordingly before you download your package!

To create a page for streaming media, open the media in a new browser window and copy the share link or page URL:

Then return to the Document Ninja, and click the ‘PASTE in a link’ button above the file list – a text box will appear, allowing you to paste in the URL you copied.
Once it’s placed, click the *Insert* button. A page with the video will be added to the file list, which can be edited and reordered as needed.

You will also have an additional option to choose how much of the media should be viewed before it will count as being completed, via an adjustable percentage slider under the title text field.
Adding a Quiz

We also have an option for adding quizzes to your course. If you want to add a quiz page, stay in the Add Documents section and click the QUIZ wizard button.

A new page will appear at the bottom of your file list. Click on it to open the Quiz Wizard. This is where a quiz’s settings and questions can be customized.

To preview and test a quiz page, click the View button to the right of the title text field.

NOTE: You will need to save either the settings or questions in your Quiz at least once before the View option will work!

When you are done previewing the quiz page, click the Edit button to return to the Quiz Wizard.
Quiz Settings

The first group of options determines how a quiz functions and what features it has.

Title: Text field allowing you to enter a custom title for the quiz.

NOTE: This does not change the title of the page – to do that, use the normal text field above the Quiz Wizard!

Mark answers: Dropdown menu allowing you to choose how questions are marked:

- **Check answer button, show status**: Questions have a Check Answer button, allowing you to mark them immediately after answering if the user chooses, upon which the button is replaced with the Next question button. Correct or incorrect questions are indicated using green or red colours.
- **Mark on completion, show status**: Questions only have the Next question button. Answers will not be marked until the user accesses the Results page. Correct or incorrect questions are indicated using green or red colours.
- **Mark on completion, do not show status**: Questions only have the Next question button. Answers will not be marked until the user accesses the Results page. Correct or incorrect questions are not indicated.
**Question ordering:** Dropdown menu allowing you to choose how questions are ordered:

- **Random order:** Questions are presented in randomized order.
- **Natural order:** Questions are presented in order they are arranged in the editor.

**Show questions:** Number field allowing you to choose how many of your total questions will be loaded by the quiz.

**Pass mark:** Number field allowing you to choose how many of your questions you need to answer correctly to pass the quiz (this cannot exceed the Show questions value).

**Results button text:** Text field allowing you to enter a custom label for the Results button (this button shows the Results page and marks all the questions).

**Answer button text:** Text field allowing you to enter a custom label for the Check Answer button (this button marks only the current question).
**Next question button text:** Text field allowing you to enter a custom label for the *Next question* button (this button moves you forward one question).

![Next question button text](image)

**Resit button text:** Text field allowing you to enter a custom label for the *Resit* button (this button allows you to reattempt the quiz if you failed).

![Resit button](image)

**Resit button:** Checkbox allowing you to enable / disable the *Resit* button.

*NOTE: Even if enabled, the Resit button will only be shown as long as the user scores less than the required pass mark. Once the user passes, the button will be disabled anyway.*

**Results page template:** Text field allowing you to enter custom text for the *Results* page. If you want the default text and coding back, click the *Reset* button at the top right of the text field.

![Results page template](image)

**Button colour:** Field allowing you to pick a custom colour for highlighted quiz buttons. Click the text box to open a colour palette, or type in a colour hex code (e.g.: #1a2b3c)
To save any setting changes, click the *Save Settings* button in the bottom right corner of this section.

**NOTE:** Saving here does not save content in the Question area – be sure to save changes made there with its own save buttons!
Quiz Questions

The second group of options allows you to add questions and customize their content.

At the top of this area, your questions are listed as numbered buttons. Click on a number button to edit that question. If you have set Question ordering in Quiz Settings to Natural order, you can also click and drag them left and right to rearrange them.
To add a new question, click the purple + button to the right of the numbered question buttons.

To type in your question, click on the Question text field, delete the placeholder text and type in your own content.

You also have the option to add media to the question by using the Question media field immediately above the Question text field. Simply drag an image file into the field (it will be converted to HTML code) or copy and paste the embed code for streaming media (YouTube, Vimeo, Soundcloud, etc). When the course is played, the content should appear above the question text.

NOTE: Since this field uses HTML, you can add more tags (such as <center> and <br>) if you need to adjust the media’s appearance and positioning!

To type in your answer choices (referred to in the wizard as ‘distractors’), click on any of the Distractor text fields, delete the placeholder text and type in your own content.
To designate which distractors are Correct, click the checkboxes to the left of the distractor text field. You can select only one for a single choice question (with radio button input) or select several at once for multiple choice questions (with checkbox input).

To delete a distractor, click the small x button to the right of the distractor text field. The distractor will immediately be removed.

To add a new distractor, click the small + button to the right of the Show field.

To control how many distractors will be loaded by the question, click on the Show number field and change the value. If the number is lower than the total amount of distractors, the distractors will be randomized when the quiz is played. If the number is the same as the total amount, the distractors will be in the order they appear in the wizard.

To rearrange distractors, click and hold the mouse in the small blank area below the Correct checkboxes, then drag up or down the distractor list.
You also have the option to add feedback messages that display after a question has been marked. Simply click the text fields and type in your messages. These apply to individual questions, so feedback messages can be different between each question if you wish.

*Feedback when correct* messages show when the question has been marked and answered correctly.

![Feedback when correct example](image)

*Feedback when incorrect* messages show when the question has been marked and answered incorrectly.

![Feedback when incorrect example](image)
Feedback when skipped messages show when the question has been marked but no answer has been submitted (in other words, if you marked the whole quiz without attempting the question).

To save any question changes, click the Save button in the bottom left corner of this section. You can also click the Save + Add New button to save and add a new question at the same time.

To delete a question, click the Delete Question button in the bottom right corner of this section. The question will immediately be removed, so be sure you want it gone before clicking!
Choosing the design of your course

When you have uploaded all your documents and arranged all your pages, the next step is to select your course navigation layout. To do this, open the Choose a Design section.

To select a design, simply click a thumbnail once and it will be selected.

We have five basic designs to choose from in the Basic category – Carousel, Drop Down, Drop Up, Nano and Side Bar. We also have a single design to choose from in the None category – No Design.

For the purpose of these templates, we will not use designs from any other category.

To change the colour of a design, click in the text box at the top of the page and either select a colour from the palette that appears, or type in a hex code (e.g: #1a2b3c). The basic theme thumbnails will change colour accordingly, to give a preview of how the designs might look.
Carousel

This design features Previous and Next navigation buttons on the left and right sides of the window.

It also features a thin, transparent progress bar at the very top of the window, that fills as you move through the course.

Course introduction

Welcome to my course! This is dummy text in order to show the template in the Document Ninja and to appear in screenshots for the documentation. This is some more dummy text in order to fill out this paragraph to appear like a typical introduction page for a course. Since we’re working in Word and Powerpoint, you should be able to use all the standard formatting features they allow – such as the bullet points just below here, for instance! Here’s some good old lorem ipsum to round this off. Nulla facilisi. Duis a vehicula mauris, et lobortis ligula. Nam posuere nunc ac orci faucibus, eget interdum leo sollicitudin. Aenean non augue in nisi feugiat finibus et vel tellus. Pellentesque in dolor rhoncus, molestie neque eu, tincidunt ante. This Document Ninja is just one of the many great Ninja apps we have on offer. If you’ve just bought the bundled collection of apps, you should be able to enjoy the following:

- Wrapping streaming media from YouTube, Vimeo and Soundcloud easy with the Media Ninja!
- Create your own custom SCORM courses from scratch with the Course Builder!
- Quickly and easily testing your courses with the SCORM Preview Ninja!
- And hopefully many more in the future as we develop them!


Head off to the next page to get started....
**Drop Down**

This design features Previous and Next navigation buttons in a bar at the top of the window, along with the current page title.

It also features a table of contents that can be expanded and hidden by clicking a button on this same bar. The contents area also displays the course title, page titles and copyright information.
Drop Up

This design features Previous and Next navigation buttons in a bar at the bottom of the window, along with the current page title.

It also features a table of contents that can be expanded and hidden by clicking a button on this same bar. The contents area also displays the course title, page titles and copyright information.

Course introduction

Welcome to my course! This is dummy text in order to show the template in the Document Ninja and to appear in screenshots for the documentation. This is some more dummy text in order to fill out this paragraph to appear like a typical introduction page for a course. Since we’re working in Word and Powerpoint, you should be able to use all the standard formatting features they allow – such as the bullet points just below here, for instance! Here’s some good old lorem ipsum to round this off. Nulla facilisi. Duis a vehicula mauris, et lobortis ligula. Nunc posuere nunc ac orci faucibus, eget interdum leo sollicitudin. Aenean non augue in nisi feugiat finibus et velit tellus. Pellentesque in dolor rhoncus, molestie neque eu, tincidunt ante.

This Document Ninja is just one of the many great Ninja apps we have on offer. If you’ve just bought the bundled collection of apps, you should be able to enjoy the following:

- Wrapping streaming media from YouTube, Vimeo and SoundCloud easy with the Media Ninja!
- Create your own custom SCORM courses from scratch with the Course Builder!
- Quickly and easily testing your courses with the SCORM Preview Ninja!
- And hopefully many more in the future as we develop them!


Head off to the next page to get started...
Nano

This design features transparent Previous and Next navigation buttons in the bottom right corner of the window, along with the current page number.

It also features a thin, transparent progress bar at the very top of the window, that fills as you move through the course.

Course introduction

Welcome to my course! This is dummy text in order to show the template in the Document Ninja and to appear in screenshots for the documentation. This is some more dummy text in order to fill out this paragraph to appear like a typical introduction page for a course. Since we’re working in Word and Powerpoint, you should be able to use all the standard formatting features they allow – such as the bullet points just below here, for instance! Here’s some good old lorem ipsum to round this off. Nulla facilisi. Duis a vehicula mauris, et lobortis ligula. Nunc posuere nunc ac orci faucibus, eget interdum leo sollicitudin. Aenean non augue in nisi feugiat finibus et vel tellus. Pellentesque in dolor rhoncus, molestie neque eu, tincidunt ante.

This Document Ninja is just one of the many great Ninja apps we have on offer. If you’ve just bought the bundled collection of apps, you should be able to enjoy the following:

- Wrapping streaming media from YouTube, Vimeo and SoundCloud easy with the Media Ninja!
- Create your own custom SCORM courses from scratch with the Course Builder!
- Quickly and easily testing your courses with the SCORM Preview Ninja!
- And hopefully many more in the future as we develop them!


Head off to the next page to get started...
Side Bar

This design features Previous and Next navigation buttons in a bar on the left side of the window, along with the current page title.

It also features a table of contents that can be expanded and hidden by clicking a button on this same bar. The contents area also displays the course title, page titles and copyright information.

Course introduction

Welcome to my course! This is dummy text in order to show the template in the Document Ninja and to appear in screenshots for the documentation. This is some more dummy text in order to fill out this paragraph to appear like a typical introduction page for a course. Since we’re working in Word and PowerPoint, you should be able to use all the standard formatting features they allow – such as the bullet points just below here, for instance! Here’s some good old lorem ipsum to round this off. Nulla facilisi. Duis a vehicula mauris, et lobortis ligula. Nunc posuere nunc ac orci faucibus, eget interdum leo sollicitudin. Aenean non augue in nisi feugiat finibus et velit tellus. Pellentesque in dolor rhoncus, molestie nec eu, tincidunt ante.

This Document Ninja is just one of the many great Ninja apps we have on offer. If you’ve just bought the bundled collection of apps, you should be able to enjoy the following:

- Wrapping streaming media from YouTube, Vimeo and SoundCloud easy with the Media Ninja!
- Create your own custom SCORM courses from scratch with the Course Builder!
- Quickly and easily testing your courses with the SCORM Preview Ninja!
- And hopefully many more in the future as we develop them!


Head off to the next page to get started....
No Design

This design has no features or navigation buttons whatsoever. It only displays the very first page in the course and users cannot navigate to other pages.

Since only one page is shown, this design is best used only for single-page courses.
Downloading your course package

Once you have selected the layout for your course, the last step is to enter a course’s descriptive information and completion settings. To do this, open the **Download your Package** section. You will have several options available.

<table>
<thead>
<tr>
<th>Package Name (required)</th>
<th>Tutorial course package</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description (short, optional)</td>
<td>Each of these files will prove useful for your further education.</td>
</tr>
<tr>
<td>Copyright (optional)</td>
<td>© Somebody</td>
</tr>
</tbody>
</table>

The three text boxes at the top of this area are used to give the package a name, give it a short description and add a copyright statement respectively. The last two are optional, but the package cannot be downloaded if it does not have a title!

**NOTE:** To enter a copyright symbol, hold the Alt key and press 0169 on the numpad (Windows) or hold the Option key and press G (Mac).

This choice will determine whether the user can open any page at any time during the course, or whether they will be barred from skipping ahead until previous pages have been completed. Choose either setting by clicking the radio button next to it.

This choice determines whether the course is completed by the user visiting the last page, or whether they must visit a set number of pages beforehand. Choose either setting by clicking the radio button next to it, and click the number drop down menu to choose the number of pages.

This choice determines what SCORM format the package will use, though in most cases this can just be left on its default SCORM 1.2 setting. If you wish to change it for any reason, choose your preferred setting by clicking the radio button next to it.
Finally, you have three choices at the bottom of the page:

- **Clicking** *Download zip* **immediately downloads your course package as a ZIP file, saving it to your computer.**

- **Clicking** *Save to Cloud* **opens a popup displaying the cloud storage services you have connected to the Document Ninja. If you already have some connected, choose a location to save the ZIP file and it will be sent to your storage account.**

- **Clicking** *Open in Preview Ninja* **will launch the Preview Ninja in a new browser tab and upload the course package to it, allowing you to test out how the course will appear and function when accessed by other users.*
Previewing the course package does not save it, so you will still need to use either of the two previous choices to save the file for uploading to your Learning Management System.

**Additional notes**

These templates have been designed for the 'Embedded SCORM package' size in the Preview Ninja, and the assumption the size they will be displayed at in your Learning Management System is **1000 pixels wide by 650 pixels high**. Displaying at other sizes may have differing results.

If you need to go back and make any changes in sections you have already visited, you can switch between the **Add your Documents, Choose a Design** and **Download your Package** sections at any time.

If you want to start over from scratch, you can do so by clicking the **Reset** button in the top right corner of the Ninja. Clicking this button will give a prompt to confirm the action – if you click Yes, the Ninja will be wiped clean. Once this has occurred it cannot be undone.

If you need more information on how to use the Document Ninja, further documentation for the app is available by clicking the **Help** button in the top right corner of the Ninja.